will420's avatar

will420

Noob (3)
Member
Dec 22, 2016
08:17 pm

G'day, my front sram guide rs brake seems to be playing up a bit. Once I pull the lever in, it doesn't seem to be returning to its proper position, or does so extremely slowly. If the bike has been sitting in the sun for a while or in a hot place the lever doesn't return at all after being pulled in. Recently had my local bike shop bleed it and it was fine for 2 rides but now the problem is reoccurring. Does anyone know what might be causing this?

Thanks in advance for any advice

 
mark22's avatar

mark22

Noob (38)
Member
Dec 22, 2016
11:24 pm

Buy a set of XT or XTR s online Wink Torp 7, Wiggle or CRC

Seriously though they are more trouble than they are worth.

http://www.rotorburn.com/forums/showthread.php?304656-SRAM-Guide-RS-Brakes-Lever-slow-to-return&highlight=guide+brakes+slow+return

 
mtbhurt's avatar

mtbhurt 46

Gumby (86)
Member
Dec 26, 2016
07:06 am

How old are your brakes will420? If they are still under warranty then SRAM should sort then out for you.

The issue is apparently to do with the plastic plunger in the lever, it somehow expands or deforms such that the internal spring can't fully push it back out when you release the handle. There are replacement lever internals kits which have an updated plunger design which should help.

 
Lex76's avatar

Lex76

Noob (3)
Member
Dec 27, 2016
11:16 am

Yep I had the same issue on my Trance if they've been in the sun it happens - in worst case the brake locks on. SRAM replaced both under warranty. They don't have the same issue any more but I still wouldn't recommend them really long pull not progressive at all am going to look into replacing them.